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Exercise 3.1 Introduction 
 
The data joining step is often a prerequisite for mapping and spatial analysis. Creating a 
color-shaded map (also known as a choropleth map), is a good first step in geographic 
data visualization and analysis. 
 
Most demographic and health data is stored in tables.  In order to make a map of these 
data, they need to be associated with (joined to) spatial data files.   
 
It is important to consider some basic database rules.  Since the shapefile contains 
multiple, unique records, the data to be linked must be in the same form.  If a name field 
is used for linking, ensure that the spelling is exactly the same.  Preferably, linking will 
be done using codes, such as “District ID”, which are stored in both the data table and 
the shapefile. 
 
Objectives: 
 

• Open and examine a data file containing HIV prevalence data by district for 
Rwanda. 

 
• Open and examine a shapefile that contains the administrative boundaries for the 

districts of Rwanda. 
 

• Join the attribute table containing HIV prevalence data to the shapefile, and save 
the result as a new shapefile. 

 
• Examine the new shapefile and revise the column names to be more meaningful 

using the Table Manager plug-in. 
 

 

Requirements: 
To complete these exercises, you will need to have QGIS and several plugins installed 
on your machine, as instructed in exercise 2.1.  You will also need to have downloaded 
and unzipped the data files associated with the exercise.  Remember, these files can 
reside anywhere on your computer, but must be kept together, with the same original 
file structure. 
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Exercise 3.1:  Join Attribute Data to a Shapefile 
 
In this exercise, you will learn how to join a text file containing HIV prevalence data from 
the Rwanda DHS 2010 final report to a shapefile representing the districts of Rwanda. 
You will then learn how to create a color-shaded map to show HIV prevalence by 
district. 
 

Task Overview: Join an attribute table containing HIV prevalence data to the geometric 
shapes in a shapefile. 
 
Background: 

At some point in time, the majority of indicator data are stored in stand-alone tables. In 
order to make a map using these data, the data must first be associated with spatial 
features, such as administrative division boundaries or health facility locations. 

As you may recall, a common format for storing spatial data is the shapefile. Before 
joining attribute data to a shapefile, it is important to take into account certain 
characteristics of shapefiles: 
 

• The geographic entities described in a shapefile are of type vector-based data, 
which means they will be collections of points, lines, or polygons. 
 

• Before attribute data, such as HIV indicators, are joined to a shapefile, the 
shapefile will contain only the physical properties (such as the latitude, longitude, 
altitude, length, or area) of the geographic entities of interest, along with one or 
more geographic identifiers, such as administrative name and/or code. 

 
• Before using common geographic identifiers to join attribute data to a shapefile, 

the attribute data and shapefile data must be referred to at the same geographic 
level. For example, attribute data for second-level administrative divisions, such 
as districts, will need to be aggregated prior to joining them to first-level 
administrative divisions, such as regions or provinces. 

 
• “Shapefiles” are actually a collection of at least three files: 

 
— Main file, which contains the geographic coordinates that make up the 

features described (e.g., administrative divisions or health facility locations). 
 Example: regions.shp 

— Index file, which identifies the byte number offset of each main file record 
from the beginning of the main file. 
 Example: regions.shx 
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— dBASE table, which contains attributes for features represented in the main 
file. 
 Example: regions.dbf 

 
Source: http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf 
 

• If a field containing names is used to join attribute data to a shapefile, it is 
necessary to make sure that the spelling of the names is the exact same in the 
stand-alone attribute table and the dBASE table that is part of the shapefile. 
 

• To avoid having to identify and correct spelling differences in names when joining 
attribute tables to shapefiles (for example, “Nyarugenge” vs. “NYARUGENGE” 
vs. “Nyrau Genge”), it is recommended to base the join on unique administrative 
codes (for example, district ID = RW0101). 

http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf
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Step 1:   Open and examine a file (a data or attribute table) containing HIV prevalence 
data. 
 
� Launch QGIS with a blank (new) project document. 

You should have a shortcut for QGIS on your desktop.  If yes, click on it to 
launch QGIS. 

 
If not, on the Windows desktop click on Start > All programs > QGIS Dufour > QGIS 
Desktop 2.0.1. 
 

� Open a comma-delimited file containing HIV prevalence data. 
 

• A comma-delimited text file (extension .csv) has been created for this exercise, 
as the comma-delimited format is a common file exchange format that can easily 
be produced using Excel or other spreadsheet or database programs. 

 
— When opening a comma-delimited file with the .csv extension, QGIS assumes 

that all fields (columns) contain strings (text) unless the field types* are 
specified in an accompanying CSVT (CSV template) file. 
 

— A CSVT file name must have the same file name and path as the CSV file it 
describes, except the file extension is .csvt instead of .csv. For this exercise,  
the CSV and CSVT file names are as follows: 

 
 CSV file: gis_exercises\data_tables\ RWA_DHS2010_TableD91.csv 
 CSVT file: gis_exercises\data_tables\ RWA_DHS2010_TableD91.csvt 

 
— A CSVT file contains a single line of information that specifies the types of 

columns contained in the CSV file as well as the maximum size of the values 
contained in those columns. The contents of the CSVT file for this exercise 
are as follows: 

 
"string(10)","string(4)","real(4.1)","real(4.1)","real(4.1)" 
 
This information indicates that the CSV file has five columns. The first two 
columns contain strings (text), with a length of 10 characters and 4 
characters, respectively. The last three columns contain real (floating point) 
numbers with a total length of 4—including the decimal—and a precision 
(number of digits after the decimal) of 1 (for example, a value of 10.1).  

 
*A “field type” refers to the way a database expects to see data stored in a particular field.  The most common field 
types are “text” (also known as “string”) or integer (for numeric whole numbers) or float (for numeric decimal values). 
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• To view the CSV file in QGIS, on the toolbar for managing layers click on the Add 

Vector Layer button.  
 

• In the Add vector layer file dialog box that appears (see below), make sure the 
source type is set to File and click on Browse. 
 

 
 

• In the file dialog box that appears (see below): 
• Use the pull-down menu in the lower-right corner to set the file type to 

“Comma Separated Value [OGR] (*.csv *.CSV).” 
• Navigate to the folder “gis_exercises\data_tables” and find the comma-

delimited text file RWA_DHS2010_TableD91.csv. 
• Click on the file name RWA_DHS2010_TableD91.csv so that it appears in the 

file name box. 
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• Click on Open. When the Add vector layer file dialog box reappears with the full 

path to the CSV file indicated in the Dataset field (see below), click once again on 
Open. 

 

 
 
� After clicking on Open for the second time, you should see a new layer in the 

Layers window corresponding to the comma-delimited text file you just added. 
 

 
 

• To view the contents of the new attribute layer, right-click on the layer name and 
select Open Attribute Table (see below). 
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An alternative way to view the contents of the new data layer is to highlight the 
data layer name by single-clicking with the left mouse button and then going to 
the QGIS main menu and selecting Layer > Open Attribute Table (see below). 
 

 
 

After opening the attribute table, you should see a table like the following. 
 



 
 

Exercise 3.1: Join Attribute Data to a Shapefile  9 of 21 

 
 
The attribute table you added contains five fields (columns): 
 
• DHSDIST: The name of the district for which data are reported in Table D.91 

in the Rwanda DHS 2010 final report. Data type is string. Maximum length is 
10. (refer back to p.5 for a review of the CSVT file which, as you may recall, 
contains this data type information.) 

• GOVTCODE: A unique administrative code assigned to each district by the 
Rwandan government. Data type is string, NOTE;  even though these are 
numbers, the first value is actually the numeral “0”.  Sometimes numerals 
used as IDs are stored as a “string” data type.  No numeric calculations can 
be perfomed on these data. Maximum length is 4. 

• HIVPREVF: HIV prevalence (percent HIV positive) among females of 
reproductive age (age 15-49) in 2010. Data type is real (floating point). 
Maximum length is 4. Maximum number of decimal places is 1. 

• HIVPREVM: HIV prevalence among males of reproductive age in 2010. Data 
type is real (floating point). Maximum length is 4. Maximum number of 
decimal places is 1. 

• HIVPREVT: HIV prevalence among the total adult population (females and 
males) of reproductive age in 2010. Data type is real (floating point). 
Maximum length is 4. Maximum number of decimal places is 1. 

 
Note that the DHS district names are spelled using initial capital letters. For the 
government codes, the first two digits represent the province and the last two 
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digits represent the district. For example, districts 0101, 0102, and 0103 
(Nyarugenge, Gasabo, and Kicukiro, respectively), all fall into the province that 
contains the City of Kigali (province ID = 01). 
 

Step 2:  Open and examine a shapefile that contains the administrative boundaries for 
the districts of Rwanda. 

� Once again, in QGIS click on the Add Vector Layer button.  You should see 
the Add vector layer dialog box. 

 

 
 
• Click on the Browse button, and in the file dialog window that appears, use 

the pull-down menu in the lower-right corner to set the file type to “ESRI 
Shapefiles [OGR] (*.shp *.SHP).” Navigate to the folder 
“gis_exercises\shapefiles” and find the shapefile RWA_districts.shp. Click 
on the file name RWA_districts.shp so that it appears in the file name box.  
The file dialog box should resemble the one below. 
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• Click on Open. When the Add vector layer file dialog box reappears with the full 

path to the shapefile indicated in the Dataset field, click once again on Open. 
 

• You should see a new layer in the Layers window corresponding to the shapefile 
you just added. 

 

 
 

� To view the contents of the attribute table for the shapefile just added, right-click on 
the layer name and select Open Attribute Table (see below). 
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The attribute table for the shapefile you added contains nine fields: 
 
• OBJECTID: This is a unique object identifier for each row in the attribute 

table, which is assigned automatically by ArcGIS when an ESRI feature class 
is created in a geodatabase. This field exists in the shapefile because the 
shapefile was derived from an ESRI geodatabase dated April 2011, which 
was downloaded from the Web site for the Rwanda Ministry of Health 
(www.moh.gov.rw). 

• GovtDistri: A unique administrative code assigned to each district by the 
Rwandan government. The values in this field are the same as those in the 
field GOVTCODE contained in the comma-delimited text file added to the 
QGIS project earlier in this exercise. 

• PROVINCE: French province names from the MOH geodatabase. 
• DISTRICT: District names in Kinyarwanda, the native language of Rwanda. 

These are the same district names used in the Rwanda DHS 2010. 
• AREA_SQ_KM: Surface area of each district calculated in square kilometers. 
• PERIMETER_: The length of the perimeter of each district in kilometers. 
• POPULATION: Total district population from the 2000 census. 

http://www.moh.gov.rw/
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• Shape_Leng: The length of the perimeter of each district in decimal degrees. 
Note that the decimal degree, which represents an unprojected coordinate 
system, is an inconsistent and imprecise unit of measurement for calculating 
distances. The Shape Length field is created and updated automatically in 
ArcGIS feature classes, but not in shapefiles. 

• Shape_Area: Surface area of each district in decimal degrees. The Shape 
Area field is created and updated automatically in ArcGIS feature classes, but 
not in shapefiles. 

 
NOTE: The DISTRICT column in the shapefile table contains the same 
administrative names as the DHSDIST column in the attribute table containing 
HIV prevalence data from the Rwanda DHS 2010. The district names in the 
shapefile table, however, are spelled in all upper case letters. This is different 
from the district names in the attribute table containing the HIV prevalence data 
you want to join to the shapefile. As a result, you cannot use the district names 
as they are currently formatted, to join the HIV prevalence data to the shapefile. 
 
To resolve the problem you have two primary options: (1) create a new column in 
one of the tables to contain district names with the same capitalization as in the 
other table or (2) use an administrative code the two tables have in common. 
Fortunately, you have a common administrative code that can be used to join the 
two tables, GOVTCODE in the HIV prevalence table and GovtDistri in the 
shapefile table. 
 

Step 3: Join the attribute table containing HIV prevalence data to the shapefile. 
 
� First, open the Properties dialog box for the shapefile layer.  

 
• To do that, you have two options: (1) double-click on the layer name for the 

shapefile (RWA_districts) in the Layers panel, or (2) right-click on the 
shapefile layer name in the Layers panel and on the popup menu select 
“Properties.”  
 

• When the Properties window opens, highlight the “Joins” icon in the left-hand 
navigation panel by left-clicking on it (see below). 
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� Then, on the Joins screen within the Layer Properties window, click on the green 
plus sign (see below). 

 

 
 

• In the “Add vector join” file dialog box that appears, use the pull-down menus to 
specify the join layer, join field, and target field as shown below.  (NOTE:  you will 
see a box checked that says “Cache join layer in virtual memory”.  The joined 
table will only be temporary and will need to be saved separately if it is to be 
used for other tasks in the future.  This will be done at a later step.) 
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• Click on OK and inspect the Layer Properties window to verify that the join has 
been accomplished (see below). 

 

 
 
� To view the result of the join, click on OK once again to close the Layer Properties 

window. Next, right-click on the name of the shapefile layer (RWA_districts) in the 
left-hand Layers panel and choose “Open Attribute Table” (see below). 
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• When the shapefile’s attribute table opens, scroll to the right to view the new 
columns containing HIV prevalence data (see below). 

 

 
 
Note that the column names are very long, as they contain a combination of the 
input file name (RWA_DHS2010_TableD91) and the column names in the input 
file (DHSDIST, HIVPREVF, etc.). 
 
Note also that the join is temporary; the variables for HIV prevalence will not 
be permanently added to the shapefile table unless you save out a new shapefile 
using the results of this join. 
 

Step 4: Create a new shapefile from your joined data, and add it to the QGIS project. 
 
� To make the join permanent, save a copy of the shapefile containing the 

temporarily joined HIV prevalence data. To do so, perform the following tasks: 
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• Close the shapefile attribute table by clicking on the X in the red box in the 
upper-right corner of the attribute table.  
 

• Right-click on the name of the shapefile layer in the Layers panel and select 
“Save As.” 

 

 
 

• In the Save As dialog box, choose the following settings: 
 

 Format: ESRI Shapefile 
 Save as: 

Session gis_exercises\shapefiles\RWA_districts_HIV.shp 
 Add saved file to map: Click on this box so that an X appears in it. 

 
� Leave the remaining settings as they are so that the Save As dialog box looks like 

the one below. 
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Note: For now it is important to make sure that the choice for Encoding is “UTF-8” and 
the choice for CRS is “Layer CRS.” This will keep the output file in an unprojected 
coordinate reference system (CRS), which stores features using latitude and longitude 
in degrees. 

 
� Click on OK and verify that the new shapefile has been added to the Layers panel 

in QGIS. 
 
Step 5: Revise the new column names to be more meaningful. 
 
� If you recall, the new column names generated by QGIS automatically in the 

shapefile table during the join were very long. In the process of creating the new 
shapefile after the join, however, QGIS automatically shortened these column 
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names to a maximum of 10 characters. This created column names that are not 
very descriptive and therefore not very useful.  In this step we will use Table 
Manager to create new, more useful names for these columns. 

 
• To verify the new column names corresponding to the HIV prevalence indicators, 

right-click on the name of the new shapefile layer (RWA_districts_HIV) in the 
Layers panel and scroll to the right. You should see columns with abbreviated 
names as shown in the column headings below. 

 

 
 

• To change the column names, close the shapefile table, highlight the name of the 
new shapefile layer in the Layers panel, and start the Table Manager plug-in by 
going to the main menu in QGIS and selecting Vector > Table Manager > Table 
Manager (see below). 

 

 
 

 
NOTE:  If you do not see the Table Manager plug-in on the Vector menu, please 
refer back to Exercise 2.1, the “installing plugins” section. 
 

• In the Table Manager window, highlight each new variable name, click on the 

Rename button , and make the following changes: 
 

• From RWA_DHS201 to DHSDIST. This is the DHS district name. 
• From RWA_DHS2_1 to HIVPREVF. This is female HIV prevalence. 
• From RWA_DHS2_2 to HIVPREVM. This is male HIV prevalence. 
• From RWA_DHS2_3 to HIVPREVT. This is total HIV prevalence. 

 
• Save the changes to the shapefile table by clicking on the Save button at the 

bottom of the Table Manager dialog box. 
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• A new dialog box will open, which will ask you whether you want to keep the 
layer style currently applied. Answer Yes and then click on the Close button at 
the bottom of the Table Manager dialog box. 
 

• Verify the changes to the shapefile table by right-clicking on the shapefile layer 
name in the Layers panel, selecting Open Attribute Table, and scrolling to the 
right (see below). 
 

 
 

� You now have a shapefile containing attributes for each district which you can use 
for mapping and analysis of HIV data. 

 
 
Step 6:  Save the QGIS project. 

 
� To save the QGIS project with which you have been working, go to the main QGIS 

menu and select Project > Save or click on the Save button.  
 

• In the file dialog box that appears, specify the following output name: 
 
Session 3 HIV Data Sources\exercises\qgis_exercise_3.1.qgs 
 
 

� Quit QGIS. 
 

• To close QGIS, go to the main menu and select Project > Exit QGIS or use a 
combination of the Ctrl and Q keys (see below). 
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NOTE on joining other types of data files:  
 
QGIS can also join other types of data files to shapefiles.  All that is required is that both 
files (the attribute data and the shapefile) have a field in common on which to perform 
the join (such as a geographic identifier code).   
 

• Use Excel files (with the file name extension .xlsx or .xls), or DBF files, which 
are dBASE files with the file name extension .dbf.  

 
To use these files without losing the intended formatting for each of the data fields, 
make sure the column types (cell formats) are specified in the source files before 
attempting to join them.  
 
To add one of these file to QGIS, use the following steps: 
 

• Click on the Add Vector Layer button.  
 

• In the Add Vector Layer dialog box, click on Browse.  
 

• In the file dialog box that opens, change the file to “All files (*)(*.*).” 

 
 

• Specify the file name and click Open twice to open the file.  Proceed exactly as 
you did when joining a shapefile to a CSV file. 

 
END 
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